WordPress 4.0.1 update breaks forms

sergey tsyptsyn replied the topic: WordPress 4.0.1 update breaks forms

Joel Wilmoth wrote: Thank you. I do not show this update has been pushed to my WP dashboard.

The same was for me.

I downloaded and tried to install the plugin zip folder into WP and it failed as WP stated folder already existed.

The same for me.

Maybe this is an obvious question but do I need to delete the existing plug-in first prior to installing the new update? Will I lose my existing forms if I do so? Or should I wait until the update has been pushed to my wordpress site?

I deleted plugin (it did not delete forms and records), then installed Version: 2.7.20 (downloaded manually from "My Products" section). Plugin istalled normally (showing Version: 2.7.20 now).

Bit it did not fix the problem.

#19695
The topic has been locked.

oae replied the topic: WordPress 4.0.1 update breaks forms

Same for me; I've upgraded plugin to 2.7.20, but it didn't fix the issue.
Upgrade steps :
- Download new plugin release
- Uninstall plugin from the WP plugins page
- Install new plugin release

And then I check plugin version from the plugin page it show me 2.7.20, so upgrade is done.
I've disable WP cache, but still got the issue and the workaround with <code> still in use.

#19696
The topic has been locked.

sergey tsyptsyn replied the topic: WordPress 4.0.1 update breaks forms

Waiting for IE fix.

#19698
The topic has been locked.

edsel replied the topic: WordPress 4.0.1 update breaks forms

mine works on <code> make sure your on the TEXT mode. Will not work in Visual.

#19701
The topic has been locked.

Annika Brage replied the topic: WordPress 4.0.1 update breaks forms

I have the same problem. Have tried the suggested solution but my form looks really awkward.

This is not acceptable. You must present a final solution NOW! My business is depending on this form and I am loosing customers.

PLEASE solve the issue!

#19702
The topic has been locked.

oae replied the topic: WordPress 4.0.1 update breaks forms

Hello Annika,

As I told before I got the issue due to WP upgrade, on customers websites, and before or after plugin upgrade the way to fix it is to edit your page(s) with the text editor and add the 'code'.
At the moment you have something like :

[Form id="10"]
And at the end you should have something like :
<code>[Form id="10"]</code>

That's more a workaround the issue than a fix, but it works well for me before and after plugin upgrade, so websites looks good to visitors.

But I agree with you a clean fix to the issue should be release quick and tested, not like previous plugin release which was told to solve the issue but not really...

#19703
The topic has been locked.

Annika Brage replied the topic: WordPress 4.0.1 update breaks forms

Thank you but I've tried everything you suggest - been there, done that. It does not look good for my visitors or for me - the fields are crawling beyond the page limits and I have a professionell theme. And I had the last plugin upgrade...

Hopefully this would be fixed soon but now I've been waiting almost 12 hours. :-)

#19705
The topic has been locked.

oae replied the topic: WordPress 4.0.1 update breaks forms

Maybe you can check if there's some upgrade for your theme. On my side, themes are children from the wunder on which I've done some customizations and I've no problem with form fields.

But, now I'm thinking... I've done some modifications on the form layout ; I've remove all markup which was unecessary like those for having a paginated form, which are in the layout by default. Maybe check in the layout of your form if you can make some quick CSS or markup fix.
I know that's not a good solution, but it can safe a little part of your business ;)

#19706
The topic has been locked.

sergey tsyptsyn replied the topic: WordPress 4.0.1 update breaks forms

oae, this is browser dependent problem. It looks ok (with <code> hack) in FF and Chrome. But in IE it is really ugly. It was not ugly before WP update. So we expect plugin update, not our different themes update.

#19711
The topic has been locked.

Annika Brage replied the topic: WordPress 4.0.1 update breaks forms

Yep, and it looks ugly in Safari too... :-/

#19713
The topic has been locked.

Rodney Crawford replied the topic: WordPress 4.0.1 update breaks forms

Rob Meinzer wrote:

Rob Meinzer wrote:

Nicole Ehrlich wrote: I had the same issue...

just fixed it by wrapping the shortcode in the code tag

ex: <code>[Form id="14"]</code>


Thanks for the suggestion but this did not fix my forms.


I stand corrected. I was in the 'visual' edit mode. This fix works ok in the HTML edit mode.




Works great! Thank you so much. Only wish I did not have to do this, but at least it works! Thank you again

#19714
The topic has been locked.

Rodney Crawford replied the topic: WordPress 4.0.1 update breaks forms

sergey tsyptsyn wrote: oae, this is browser dependent problem. It looks ok (with <code> hack) in FF and Chrome. But in IE it is really ugly. It was not ugly before WP update. So we expect plugin update, not our different themes update.


It looks like a kindergartner wrote it! Horrible looking indeed.

#19715
The topic has been locked.

oae replied the topic: WordPress 4.0.1 update breaks forms

sergey tsyptsyn wrote: oae, this is browser dependent problem. It looks ok (with <code> hack) in FF and Chrome. But in IE it is really ugly. It was not ugly before WP update. So we expect plugin update, not our different themes update.


So first, I'd like to say that I'm not a member of the plugin's dev team nor from WP, but I'm a dev .

In my cases, forms are ok on IE, FF, Chrome, Chromium, Safari, Opera, on Windows 8.1, Ubuntu 12.04 and Mac OS X Yosemite.
The only modifications I've done on my forms are about the layout (direct from the module), and if you have some issue depending the browser for me it sounds like a CSS problem and more when hearing about IE. Depending on how CSS is built in your theme, WP upgrade could have a side effect affecting your theme (don't forget to purge your cache if you have enable cache).

I'd like to have a clean fix too, provided by the plugin's editor. But unfortunately at this time, plugin's editor remains silent. My posts are just some suggestions for finding a way to fix it on your sites as we don't know when a fix will be released.

#19716
The following user(s) said Thank You: sergey tsyptsyn
The topic has been locked.

Lorianne Holt replied the topic: WordPress 4.0.1 update breaks forms

I've just logged in to download the latest update and for the life of me, I don't see where to access the download?? Can someone help?? I heard that the last update isn't working, but I'd like to know where to go when there's an update to the update...........LOL.

#19717
The topic has been locked.

oae replied the topic: WordPress 4.0.1 update breaks forms

Lorianne Holt wrote: I've just logged in to download the latest update and for the life of me, I don't see where to access the download?? Can someone help?? I heard that the last update isn't working, but I'd like to know where to go when there's an update to the update...........LOL.


Hi Lorianne,
when you're logged to your webdorado account, on the top of the page you have a link "My Products", click on it. Then you'll see a table in which you have all products you bought and on the right you'll have a "Download" link ; this is the link for downloading the latest version, but no need to install it now ; things won't be different than with the <code> "solution"...

#19718
The following user(s) said Thank You: Lorianne Holt
The topic has been locked.

Lorianne Holt replied the topic: WordPress 4.0.1 update breaks forms

Ugh! I must have changed my user name and password when I made my second purchase it July because I don't see My Products in the corner. Ohhhh crap.

#19719
The topic has been locked.

Lorianne Holt replied the topic: WordPress 4.0.1 update breaks forms

Logged out and logged back in and voila....there was the banner, came to the forum and it disappeared, but now I know where to find it.....LOL. Now, hopefully there is an update soon!
Thanks for your help!

#19720
The topic has been locked.

Greg Bilyk replied the topic: WordPress 4.0.1 update breaks forms

I have the same problem. Using <code> works for now but formatting is horrific.

#19721
The topic has been locked.

Tim Blume replied the topic: WordPress 4.0.1 update breaks forms

This worked for me after my second try. Formatting didn't look bad at all either. Thank you so much! you truly saved my ass.

#19723
The topic has been locked.

Support replied the topic: WordPress 4.0.1 update breaks forms

Dear all,

The issues with the Form Maker/Form Builder/Contact Form Maker are caused by the latest update of WordPress to 4.0.1.

If you have a Form Maker/Form Builder/Contact Form Maker, which is not customized, please update to the latest version. The latest version can be found in WordPress if that’s a free version or your account (My Products) section, if that’s a Pro (paid) version.

Please note that after the update you will have to regenerate the shortcode. That is to delete and insert the shortcode from the Editor again.

Please note: if you have a customized version, please contact us to [email protected], providing temporary full Admin access, so that we will make the changes within the product code, so that that customization will not be lost.

Thank you.


Best regards,
Web-Dorado team


Joomla extensions ,
Wordpress plugins ,
Drupal modules
#19726
The topic has been locked.

oae replied the topic: WordPress 4.0.1 update breaks forms

Dear Support,

I've made the upgrade yesterday, with no changes. Today, what I did is :
* remove short code from a page
* save the page
* check the page as a visitor => no form to view => OK
* edit the page again with the visual editor
* add the form from the dialog box
* save the page
* check the page as a visitor => fail with this render :

[Form id= »13″] 

* edit the page again
* add "<code>"
* save page
* things are ok

So I can't consider the issue as fixed.

To me it seems there's a parsing problem, but I don't know WP and plugin code, and I don't have time to debug myself, but at the moment we can clearly say that there's a problem with the plugin rendering.
By the way I don't think this is due to my layout modification (using plugin layout editor).

#19734
The topic has been locked.

Support replied the topic: WordPress 4.0.1 update breaks forms

Dear customer,

So as I understand, this happens after you insert a new shortcode of the updated Form Maker (version 2.7.20)? Could you please give us (to [email protected]) admin access to your site?

Please indicate the full link of your forum post in your email subject. We'll try to fix the problem as soon as possible.
Thank you.


Best regards,
Web-Dorado team


Joomla extensions ,
Wordpress plugins ,
Drupal modules
#19736
The topic has been locked.

Rosemary replied the topic: WordPress 4.0.1 update breaks forms

We are having the same issues. Currently using the code hack. I am using a paid version so why do I not see any plugin update when I log in here? I click on 'my products' and it says, you have no subscriptions.

#19744
The topic has been locked.

sergey tsyptsyn replied the topic: WordPress 4.0.1 update breaks forms

I've made the upgrade.
Today I:
* create new page, save it
* check the page as a visitor => no form to view => OK
* edit the page again with the visual editor
* add the form from toolbar (Insert Form Maker)
* save the page
* check the page as a visitor => fail with this render :
[Form id=»15″]

#19748
The topic has been locked.

Gene replied the topic: WordPress 4.0.1 update breaks forms

Good time everybody, I've just encountered the same bugs with this plugin, but I found out next issues with misbehavior of a new script - when I switch admin side language to american english, shortcode works just as it was on WP 4.0, but when I switch language into russian shortcode on admin side looks like - [wd_contact_form id="9"], but on visitor side it looks like this - [wd_contact_form id=»9″] . Thats it, I did not figured out yet what specifically causes such substitution of »quotes" but I hope that dorado team would find the solution soon. Aditional tag like <code> </code> solves problem but adds extra space before and after "form" which makes page look ugly, for now I just downgraded WP back to 4.0. Wating for updates. God bless.
PS For Web-Dorado team - I took care about cache, it does not make any difference. On the very next line I have shortcodes created by other plagin with a similar spelling and "quotes" they works perfect.

#19749
The topic has been locked.

Time to create page: 0.278 seconds
Powered by Kunena Forum

WORLD-CLASS SUPPORT

We are here for you every step of the way. Turn to our support with any questions you might have about our products and services. Our experienced customer care team is available to help you as fast as we possibly can.

Contact us