News Magazine - image in post causes homepage to fail

Graham created the topic: News Magazine - image in post causes homepage to fail

Hi,
Experimenting with my first post. If I make a new post with just text, all is OK. If I add an image in the text, the post displays OK but I cannot access the homepage at all - when I click 'Home' I just get a time-out after a minute. This is the same whether I create a new post or modify the default one. Removing the image restores funtionality.

The development location is www.mostlyfood.co.uk/wp/ . The images are from 2kb to 90kb - not big - and they uploaded correctly to www.mostlyfood.co.uk/wp/wp-content/uploa...17/11/image-name.jpg .

Anyone got any pointers, please? I'm assuming there's some setting somewhere, but can't find anything relevant.
Thanks.

#92051

Please Log in or Create an account to join the conversation.


Anoush replied the topic: News Magazine - image in post causes homepage to fail

Hello Graham,

Thanks for your post!

Most probably the issue is related to your server. When we try to go to the link you provided we got the 504 Gateway Time-out The server didn't respond in time error. Have you faced the same issue if you activate one another theme (for example one of WordPress standard theme)?

Thanks and have a wonderful day!

#92075

Please Log in or Create an account to join the conversation.


Graham replied the topic: News Magazine - image in post causes homepage to fail

Thanks, Anoush. I have just tried the Wordpress 2016 theme, and it works fine, though it doesn't look great so I guess we need to go looking for another theme. Please say if there's a fix for News Magazine, as it looks exactly right for us!
Thanks, Graham.

#92085

Please Log in or Create an account to join the conversation.


Graham replied the topic: News Magazine - image in post causes homepage to fail

More information: I tried several other themes and they all worked ok. So I deleted the NewsMagazine theme and reloaded it. It worked OK with the posts I had added previously. Then I added a new post, and it did not work again. By a process of elimination I discovered that the cause of the failure was the absence of a 'Featured image' - as soon as I put one in, the home page worked fine!
I hope this gives you enough info to diagnose the fault - I was under the impression that NewsMagazine would just use the first image in the article if I didn't designate one as 'featured'?

#92103

Please Log in or Create an account to join the conversation.


Anoush replied the topic: News Magazine - image in post causes homepage to fail

Dear Graham,

As the issue comes from our theme, we are kindly asking you to give us a chance to fix the issue for you. Please send us the link and the temporary admin details of your website. You can send the login details using the form on this this page.

Thanks and have a wonderful day!

#92131

Please Log in or Create an account to join the conversation.


Graham replied the topic: News Magazine - image in post causes homepage to fail

Hi Anoush, Great news! As far as I can tell, everything is working fine now. i don't know what changed, but I have tested several different ways of putting images into posts and they all work without needing a 'featured image'. And I have checked the site on another computer, and that's OK too.

So I guess some glitch has ironed itself out, and I'll accept that all is fine. Thanks for the attention you have given to my issue.

#92157

Please Log in or Create an account to join the conversation.


Anoush replied the topic: News Magazine - image in post causes homepage to fail

Hi Graham,

Thanks for letting us know about the results, it is very nice to hear!

Graham is there any chance you could share your experience on review page here

Thanks for the feedback, I really appreciate that.

#92181

Please Log in or Create an account to join the conversation.


Erick replied the topic: News Magazine - image in post causes homepage to fail

Hello! I am also having the same issue with the News Magazine theme. Since there wasn't a solution posted here, I submitted a Support Ticket, but thought I would still post here to see if either of you had any suggestions or fixes that you've come across.

Thanks!

#92269

Please Log in or Create an account to join the conversation.


Anoush replied the topic: News Magazine - image in post causes homepage to fail

Hi Erick,

Thanks for your post :)

Please follow the steps below, if you have questions and issues, please just mention the ticket number here.

In this file news_magazine_frontend_functions we have added the following code $style_img = 'height:auto; width:100%; max-width:100%;'; instead of the below code.


list($w, $h) = @getimagesize($thumb_url);
if ($w == 0) {
$w = 10;
}
if ($h == 0) {
$h = 10;
}
if ($h / $w > $height / $width) {
$scale = $width / $w;
$style_img = 'width:100%; height:auto; max-width:none; left:0; top:' . ($height / 2 - $h / 2 * $scale) . 'px;';
} else {

$scale = $height / $h;
$style_img = 'height:100%; width:auto; max-width:none; left:' . ($width / 2 - $w / 2 * $scale) . 'px;';
}


Thanks and have a wonderful day!

#92309

Please Log in or Create an account to join the conversation.


Erick replied the topic: News Magazine - image in post causes homepage to fail

Hello Anoush,

Please clarify something for me. In your message it starts of by saying "follow the steps below," but there aren't really any steps listed?

Did you already swap the codes you refer to? Or are those the steps that I need to follow?

Thanks...

This is regarding: Support ticket #282881

#92335

Please Log in or Create an account to join the conversation.


Erick replied the topic: News Magazine - image in post causes homepage to fail

Anoush,

Thank you for your help! With the code you sent us we were able to fix the problem.

Thanks!

#92341

Please Log in or Create an account to join the conversation.


Anoush replied the topic: News Magazine - image in post causes homepage to fail

Hello Erick,

I am happy to hear that the code has been useful for you!

If you require any further information, let me know.

Thanks and have a great day :)

#92361

Please Log in or Create an account to join the conversation.


Time to create page: 0.179 seconds
Powered by Kunena Forum

WORLD-CLASS SUPPORT

We are here for you every step of the way. Turn to our support with any questions you might have about our products and services. Our experienced customer care team is available to help you as fast as we possibly can.

Contact us