Lightbox: Issue in mobile view

Florian created the topic: Lightbox: Issue in mobile view

Hi Team, dear Agapi,

Thanks to your kind support, I am happily using the gallery + lightbox functionality for quite some time now. However there seems to be an issue with my galleries when viewed on mobile devices now. When turned into horizontal Position, the lightbox does not provide fullscreen functionality of the image but rather places it in / restricts it to the upper third of the Screen (pls check 1st + 3rd screenshot attached).
This is a bit annoying as a lot of space is left 'empty' and it doesn't look professional (like it did before!)
The empty gap seems to match the width of the upper URL bar (when the url bar is displayed, the image does cover the 'full screen', pls check screenshot 2).
Can you please advise? Happy to provide you with my Login in case you'd have to check it directly in my site.

Many thanks in advance!

Kind regards
Florian

#85177
Attachments:

Please Log in or Create an account to join the conversation.


Aulis Sibola replied the topic: Lightbox: Issue in mobile view

Hi Florian,

I have noticed the same thing. Did you upgrade your Google Chrome on mobile device lately? Chrome 56 f.cked up. Most of the websites are completely broken (if you are not using English on your mobile device as system language) and this location bar issue appeared then. Although there is a "fix" for messed up websites, I have not found any way to fix the "lighbox does not cover the whole window" issue.
So, basically I'm 99,9999% sure, this is Google issue and not Photo Gallery issue. And I do not know if WebDorado can make a workaround here...

The sad thing is, that Google seems to be ignoring the issue (Chrome 56 has been out for weeks now) - they only suggest some "workarounds" and not solutions....

Best regards,
Aulis Sibola

Florian wrote: Hi Team, dear Agapi,

Thanks to your kind support, I am happily using the gallery + lightbox functionality for quite some time now. However there seems to be an issue with my galleries when viewed on mobile devices now. When turned into horizontal Position, the lightbox does not provide fullscreen functionality of the image but rather places it in / restricts it to the upper third of the Screen (pls check 1st + 3rd screenshot attached).
This is a bit annoying as a lot of space is left 'empty' and it doesn't look professional (like it did before!)
The empty gap seems to match the width of the upper URL bar (when the url bar is displayed, the image does cover the 'full screen', pls check screenshot 2).
Can you please advise? Happy to provide you with my Login in case you'd have to check it directly in my site.

Many thanks in advance!

Kind regards
Florian

#85179
The following user(s) said Thank You: Florian

Please Log in or Create an account to join the conversation.


Florian replied the topic: Lightbox: Issue in mobile view

Hi Aulis,

You're correct; works with full screen functionality in my Firefox.. such a pity Chrome is the major browser these days (at least in my perception).
What's that workaround you're referring to? Is that something I can do on my Site which then solves the problem for any other Chrome visitor?

Also, webdorado Team if you're aware of a fix just let me know. Or we'll sign a petition to Google..
Thanks Guys!

Florian
infinite-colours.com

#85181

Please Log in or Create an account to join the conversation.


Aulis Sibola replied the topic: Lightbox: Issue in mobile view

Hi Florian,

Sorry, I don't know of a fix on server side. The workarounds only work on mobile device. And those workarounds do not fix the full-screen issue, only messed up (completely unreadable) websites can be made to work again. Interestingly enough - the messed up websites content is unreadable, but Photo Gallery is displayed OK ;-) But Photo Gallery backend on mobile device is completely messed up... But AFAIK WebDorado has not been able to make the backend work on mobile device anyway, so this is a "known issue".
Google's "official" suggestion is to "clear cache of Chrome app and hope for the best". Another (I can confirm it's working) fix is to change mobile device language to English (US), open Chrome, close Chrome and change the language of device back to your own language. Stupid, I know...
Especially from Google...

But, if WebDorado is aware of any solution to the full-screen Lightbox issue, I would also be interested. Because on mobile phone, the galleries are practically unusable - especially in Landscape mode, the address-bar takes a lot of space...

Hopefully Google will update the Chrome so it will work again... In fact - Chrome 56 is somewhat broken on Windows also... It's a pity indeed from the best and most popular (probably) browser...

#85189

Please Log in or Create an account to join the conversation.


Agapi G. replied the topic: Lightbox: Issue in mobile view

Hello Florian and Aulis!

Thank you so much for reporting this problem to us!

I have added a task for our development team to check and see if they can implement a workaround. If this would be possible (and I believe it will), we will include the fix in one of the next couple of updates of Photo Gallery plugin.

You can keep track of the changes in the plugin with the following link: wordpress.org/plugins/photo-gallery/changelog/

But please note to let us know in case your Photo Gallery has been customized. We will need to implement the changes manually.
Thanks! Have a wonderful day!


Kind regards,
Agapi G.
Web-Dorado team
#85273

Please Log in or Create an account to join the conversation.


Florian replied the topic: Lightbox: Issue in mobile view

Hi Agapi, my gallery's customized ;)

#85311

Please Log in or Create an account to join the conversation.


Agapi G. replied the topic: Lightbox: Issue in mobile view

Hey Florian!

In case are not in a hurry, please wait until the solution is implemented in Photo Gallery and contact our team through this form. If you provide us temporary admin access, we will make the change in your plugin ASAP.

But if you wish to have these changes sooner, you can contact us with this request now. We'll check the problem from your site.
Thank you! Have a great day!


Kind regards,
Agapi G.
Web-Dorado team
#85371

Please Log in or Create an account to join the conversation.


Time to create page: 0.173 seconds
Powered by Kunena Forum

WORLD-CLASS SUPPORT

We are here for you every step of the way. Turn to our support with any questions you might have about our products and services. Our experienced customer care team is available to help you as fast as we possibly can.

Contact us