InnoDB not required.

Plutocrat created the topic: InnoDB not required.

Hi,
I run wordpress on nginx and noticed my error.log was filling up with the following errors.

2015/10/28 03:54:49 [error] 11503#11503: *52787 FastCGI sent in stderr: "PHP message: WordPress database error Unknown storage engine 'InnoDB' for query CREATE TABLE IF NOT EXISTS `wp_contactformmaker_blocked` (
`id` int(11) NOT NULL AUTO_INCREMENT,
`ip` varchar(128) NOT NULL,
PRIMARY KEY (`id`)) ENGINE=InnoDB DEFAULT CHARSET=utf8 AUTO_INCREMENT=1 made by do_action('admin_init'), call_user_func_array, contact_form_maker_activate, contact_form_maker_insert" while reading response header from upstream

Its true that my mysql server doesn't support InnoDB. Its a small server with low traffic, and if I turn on InnoDB the database requirements take up almost the entire memory, so I disabled it.

Removing the ENGINE=InnoDB from your code in contact_form_maker_insert.php stops the error messages. I'm guessing your code will work just the same with MyISAM, so consider removing this requirement from your code, and then it will just use whatever engine is available.

#39229

Please Log in or Create an account to join the conversation.


Support replied the topic: InnoDB not required.

Dear user,

Thank you for letting us know about this! We will consider your notes when developing future updates of the product.

We are glad the problem is figured out on your website and you have Form Maker working!
Thank you.


Best regards,
Web-Dorado team


Joomla extensions ,
Wordpress plugins ,
Drupal modules
#39281

Please Log in or Create an account to join the conversation.


Time to create page: 0.159 seconds
Powered by Kunena Forum

WORLD-CLASS SUPPORT

We are here for you every step of the way. Turn to our support with any questions you might have about our products and services. Our experienced customer care team is available to help you as fast as we possibly can.

Contact us